permission to select view issue

Oct 20, 2010 at 4:09 PM

Hi Andrea,

I set up a AzmanReadOnly sql db user with netsqlazman_Readers (and db_datareader) role selected and I can't select from any view to look at data directly.

select * from netsqlazman_StoreGroupMembers comes back with no rows, however if I execute as the schema owner all data appears.  It seems your setup script (NetSqlAzMan_SqlServer.sql) has all grants that it needs, but it still doesn't work. There are no errors.

Only if I select netsqlazman_Administrators can I select data from the view netsqlazman_StoreGroupMembers and others.

Is it possible to grant a reader select rights to these views?



Oct 20, 2010 at 4:32 PM

It is by design.

If you belongs to the NetSqlAzMan_Readers role only … you have to choose for which Stores/Applications you can read.

Use NetSqlAzMan MMC/SnapIn to assign users permissions for each Store/Application:

- Right click on the Store/Application

- Properties

- Permissions.



Andrea Ferendeles
NetSqlAzMan Project Coordinator
E-mail Web

Oct 20, 2010 at 4:40 PM

That worked. Thanks.

(removed the netsqlazman_Administrator, manager and user role from SqlServer Management Studio and in Net Sql Azman console added the user to reader group)