local groups

Nov 9, 2011 at 1:25 AM
Edited Nov 9, 2011 at 1:27 AM

Hello:

Local groups don't seem to work. I have the code from my previous message (http://netsqlazman.codeplex.com/discussions/278792) and this is what I have in web.config:

 

    <roleManager enabled="true" defaultProvider="NetSqlAzManRoleProvider" >
      <!-- "AspNetWindowsTokenRoleProvider" -->
      <providers>
        <clear/>
        <add name="NetSqlAzManRoleProvider" type="NetSqlAzMan.Providers.NetSqlAzManRoleProvider"
             connectionStringName="NetSqlAzManConnectionString"
             storeName="MyStore" applicationName="MyApp"
             userLookupType="LDAP" defaultDomain="TESTDOMAIN" UseWCFCacheService="false" />
        <!--
          UseWCFCacheService:
          False: use a local instance of the StorageCache class. True: use the NetSqlAzMan WCF Cache Service (remember to add the <system.serviceModel>...</system.serviceModel> section to your web.config file)
          -->
        <!-- UserLookupType options: { LDAP, DB } -->
        <!-- Leave DefaultDomain blank if userLookupType=="DB" (DB users) -->

      </providers>
    </roleManager>

I installed the app on a Win2008R2 server. I assigned Role1 two groups, a domain group and local group (i.e. a group created on this server). I added myself to the local group. It didn't seem to make any difference even after restarting the web server.

Is this behaviour normal?

Thank you

Coordinator
Nov 9, 2011 at 8:17 AM

Local groups are not supported in a Web scenario (Web Console, ASP.NET RoleProvider)… because “local groups” means “local groups to the IIS Web Server” … so it does not have a lot of sense.