Error importing from MS AzMAn

May 27, 2009 at 3:30 PM

Hi all

I'm trying to import a store from MS AzMAn, naming it "test", but I have this error message as soon as I start the task:

---------------------------
Import from AzMan failed
---------------------------
Store Group 'Admin' not found. Store 'test'.
---------------------------

I've installed the latest release ( 3.5.4.2 )

I've tried the same thing with older releases ( 3.5.4.1 and 3.5.4.0 ) and I had an error of "Primary Key violation" in "ItemsHierarchyTable" table.

I don't know if the errors are related, I would ask if there are limitations in importing from MS AzMan.

Thanks.

Moreno.

 

May 28, 2009 at 12:34 PM
Hi Moreno,
could you send me by mail the AzMan xml file ?
Regards,
Andrea.

May 28, 2009 at 1:16 PM

Hi Andrea,
sorry, I forget to tell you I have to import from an LDAP repository, not from an XML repository....

The connection string I use is like this : msldap://myserver:389/CN=mystore,CN=Program Data,DC=develop,DC=local

Thanks for help.

Regards.

Moreno

May 28, 2009 at 2:48 PM
Hi Moreno,
Here you can find a tool for exporting AZMAN XML to AZMAN ADAM and vice-versa.
http://blogs.msdn.com/ashishme/archive/2006/12/01/azman-store-import-export.aspx
Regards,
Andrea.

May 28, 2009 at 9:44 PM
Hi Andrea.

I send you the AzMan xml file from development environment.

I hope it could be useful

Thanks in advance.

Regards.
Moreno

aferende ha scritto:

From: aferende

Hi Moreno,
Here you can find a tool for exporting AZMAN XML to AZMAN ADAM and vice-versa.
http://blogs.msdn.com/ashishme/archive/2006/12/01/azman-store-import-export.aspx
Regards,
Andrea.

Jun 3, 2009 at 3:36 PM

Hi Andrea

I only want to ask you if you' ve received the XML  I send you

Thanks

Jun 3, 2009 at 3:50 PM
No.
Where you have sent it ? (which email ?)

Jun 3, 2009 at 9:50 PM

I sent it to

netsqlazman@discussions.codeplex.com

Is it a wrong address ?

Jun 4, 2009 at 7:31 AM
Yes It's wrong. It is to asnwer to the forum posts only.
Anyway ... np.
Please send it to aferende@hotmail.com
Regards,
Andrea.

Jun 4, 2009 at 9:34 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jun 8, 2009 at 8:28 AM

3.5.4.3 release published.
Please try and let me know.

Regards,
Andrea.

Jun 8, 2009 at 1:39 PM

Hi Andrea.

I tried importing with the new version and all worked perfectly.

Thank you very much.

Moreno.