Can't get Web Console to work on Windows 2008 R2

Jul 21, 2010 at 9:58 PM

Hi there!  I am playing around with NetSqlAzMan for the first time, and it looks very promising!

However, I'm having some difficulty getting the Web Console to work.  I'm using Windows Server 2008 R2, 64 bit. The first time I installed it, I chose a standard .NET 4.0 application pool in integrated mode.  This produced the following error due to the impersonate="true" setting in the Web.config file:

HTTP Error 500.24 - Internal Server Error

An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

Based on the troubleshooting steps shown in the IIS error info, I tried using a .NET 4.0 classic application pool instead of integrated.  However, now I get a different error:

Access is denied.

Description: An error occurred while accessing the resources required to serve this request. The server may not be configured for access to the requested URL.

Error message 401.2.: Unauthorized: Logon failed due to server configuration.  Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server.  Contact the Web server's administrator for additional assistance.

So, some questions:

  • Do I need to run the web console in an integrated or classic app pool?
  • Are there other steps I need to take to get it to work after the setup has completed?

 

Thanks!

Ben Gilbert

Jul 21, 2010 at 10:07 PM

Go figure, as soon as I posted this I think I figured out the problem.

The Web.config declares that the site uses Windows authentication (authentication mode="Windows"), but the virtual directory created by the setup program does not enable any particular authentication methods - it just inherits whatever the default authentication schemes are from the web site where you install it.  In my case, my Default Web Site did not have Windows authentication enabled.

I tried for a bit getting it to work using anonymous authentication, but it seems that the app as built really wants to use Windows authentication.  So once I changed the virtual directory to allow Windows authentication, it comes up properly.

Coordinator
Jul 22, 2010 at 7:06 AM

Yes,

MSI setup try to enable Windows Authentication and disable anonymous authentication … but it depends on parent settings.

NetSqlAzManWebConsole can work in two ways:

1) Pipeline: Classic and Identity Impersonation: Enabled

2) Pipeline: Integrated and Identity Impersonation: Disabled

Regards,

Andrea.

__________________________________
Andrea Ferendeles
NetSqlAzMan Project Coordinator
E-mail aferende@hotmail.com Web http://netsqlazman.codeplex.com

Jul 22, 2010 at 3:48 PM

Great, thanks for the information Andrea!

 

Regards,

Ben