Strange CheckAccessTest results

May 28, 2009 at 6:52 PM

Hi,

If I do "Check Access Test" from the MMC, I get different results depending on if I check "UserPermissionCache", "StorageCache" or none.  With "StorageCache" checked, I seem to get the correct results, but with the others some Roles and Tasks get "NEUTRAL" instead of  "ALLOW".

I exported the entire application and imported the xml into a different database, and then it works fine on the new DB - all options give the correct "ALLOW" access.

The authorizations involve both Application Groups and Store groups. Is this a known bug?

Thanks.

May 28, 2009 at 8:42 PM

Hi usood,

which NetSqlAzMan MMC version are you using ?

When you have updated the NetSqlAzMan version (MMC) … Have you updated the NetSqlAzManStorage Database schema too ?

Regards,

Andrea.

May 29, 2009 at 3:38 PM

We were on 3.5.0.2 and are in the process of upgrading to 3.5.4.2.

We upgraded the Database, the WCF Cache and the MMC plugin. We did run the "NetSqlAzMan_SqlServer_UpgradeFromVersion_3502.sql" script.

The above issue happens both before and after the upgrade.

Thanks.

May 30, 2009 at 8:14 AM

Hi,

this bug was fixed on the 3.5.4.0 release.

I suggest you to updagrade quickly to the latest release (3.5.4.2)

Regards,

Andrea.

__________________________________
Andrea Ferendeles
NetSqlAzMan - Project Coordinator

http://netsqlazman.codeplex.com

Jun 1, 2009 at 3:51 PM

We have already upgraded to 3.5.4.2 (using the source code) but still having the same issue.

Jun 1, 2009 at 6:16 PM
Please send me the xml exported storage.
I will check.
Regards,
Andrea.

Jun 8, 2009 at 8:29 AM

3.5.4.3 release published.
Please try and let me know.

Regards,
Andrea.