Check Access Test: Get Error when attempting to change the user

May 29, 2009 at 1:42 PM

Running NetSQLAzMan on a Windows 2003 Server.  I am able to run the check access test for the user I'm logged in with but if via the MMC console I attempt to run check access test for a different user (press ...) I get an error stating that the program could not open the required dialog box because no locations can be found.  If I attempt to type the name in directly I get an error saying that the name is not properly formed.

 


Suggestions?

 


Thanks,

 

Dave

May 29, 2009 at 2:02 PM

Is the Windows 2003 Server machine joined to an AD Domain ?

May 29, 2009 at 9:49 PM

That was the issue....however, I've now run into the issue that when I define a store group or application group that is LDAP based I get an error any time I run the Check Access Test "An error occured while preparing the query "..." for execution against the OLE DB provider "ADSDSOObject" for liked server "ADSI".   The odd thing is that I can execute the LDAP query directly from the Store Group or Application Group config window.

 

 

Any thoughts?

May 30, 2009 at 7:39 AM

Do you have the same issues …also with Web Console too ?

May 30, 2009 at 3:27 PM

I have not tried this with the web console....it will take me some time to get it setup.

 

 

Dave

Jun 2, 2009 at 8:55 PM

I just got the Web Console working (had a number of issues w/ IIS permissions that prevented the site from coming up altogether) only to encounter an issue for just about any operation I pefrom; I receive an error dialog w/ the text "Error: Object reference not set to in instance of an object"  

 

Let me suggest a different tact....I have to believe the LDAP Query associated w/ store/appliction groups when checking access and that the likely cause of the issue is setup on my side.  Are there any known AD configurations that you're aware of that have caused issues in the past?  As I said in my original post it's odd that the query runs correctly when I check the query via the cofigure store/app group dialog but results in an error when I perform a check access test...

 

 

Dave

Jun 2, 2009 at 9:43 PM
Have you configured a domain user for the ADSI Linked Server into your SQL Server ?
- Security Tab,
- Option "be made using this security context"
- "MY DOMAIN\My user", "password"
Regards,
Andrea

Jun 2, 2009 at 10:01 PM

I just tried installing NetSQL AzMan on a virgin 2008 server (our target environment) and I'm experiencing similar behaviror when using the MMC snapin console,  however the error dialog may be a bit more descriptive.

 

I can run the query from 'Store Group Properties'-->LDAP Query-->Execute LDAP Query w/o issue.

 

I get the following error when running:

 

The OLE DB provider "ADSDSOObject" for linked server "ADSI" reported an error.  The provider indicates that the user did not have the permission to perform the operation.  An error occurred while preparing the query"<LDAP://DC=netdev,DC=com>;(&(objectCategory=user)(objectClass=group)))(&(objectCategory=user)(cn=Test*)));objectSid;subtree" for execution against OLEDB provider "ADSDOObject" for linked server "ADSI"

 

Honestly, I'm not all that interested in getting the web console to work but more intestested in getting the MMC console and ensuring that this will work when invoked via my application.  Also, I don't profess to be an AD expert so 

Jun 2, 2009 at 10:21 PM

W/o looking at the source code I get the feeling that the query is being ran as different users in the two different contexts.  Is this correct? 

 

Also, the account that I'm logged in as and using the MMC console as has domain admin rights.

 

 

Dave

Jun 2, 2009 at 11:19 PM

Figured out the issue....was logging into sql as local sa when I actually needed to log into the db as a domain member.

 

 

THANKS!  Works like a champ now

Jun 2, 2009 at 11:26 PM
LOL
:-)